Hướng dẫn xử lý lỗi “Invalid command ‘SetEnv trên Apache 2.4

Việc kiểm soát các biến môi trường bên trong được sử dụng bởi các module Apache khác nhau và được kiểm soát bởi module mod_env. Nếu module mod_env không được kích hoạt thì khi bạn sử dụng ‘SetEnv’ trong tập tin .htaccess sẽ gây ra lỗi.

Nhận biết

Kiểm tra error_log của Apache để biết thông tin lỗi như sau:

Invalid command ‘SetEnv’, perhaps misspelled or defined by a module not included in the server configuration

Nguyên nhân

Theo mặc định module ‘mod_env’ sẽ không được kích hoạt trong apache2.4. Điều này sẽ gây ra lỗi trên trong khi sử dụng ‘SetEnv’ trong tập tin htacess.

Để kiểm tra các module được nạp trong Apache, sử dụng lệnh sau:

# httpd -M
Server version: Apache/2.4.7 (Unix)
Server built:   Nov 30 2013 23:05:11
Cpanel::Easy::Apache v3.22.24 rev9999 +cloudlinux
Loaded Modules:
 core_module (static)
 authn_file_module (static)
 authn_core_module (static)
 authz_host_module (static)
 authz_groupfile_module (static)
 authz_user_module (static)
 authz_core_module (static)
 access_compat_module (static)
 auth_basic_module (static)
 socache_shmcb_module (static)
 socache_dbm_module (static)
 so_module (static)
 include_module (static)
 filter_module (static)
 deflate_module (static)
 http_module (static)
 mime_module (static)
 log_config_module (static)
 logio_module (static)
 expires_module (static)
 headers_module (static)
 unique_id_module (static)
 setenvif_module (static)
 proxy_module (static)
 proxy_connect_module (static)
 proxy_http_module (static)
 slotmem_shm_module (static)
 ssl_module (static)
 mpm_prefork_module (static)
 unixd_module (static)
 status_module (static)
 autoindex_module (static)
 info_module (static)
 suexec_module (static)
 cgi_module (static)
 negotiation_module (static)
 dir_module (static)
 actions_module (static)
 userdir_module (static)
 alias_module (static)
 rewrite_module (static)
 hostinglimits_module (shared)
 bwlimited_module (shared)
 suphp_module (shared)
 security2_module (shared)

Cách khắc phục

Để giải quyết vấn đề này, bạn cần phải cài đặt module ‘mod_env’ theo cách thủ công

Nếu sử dụng easyapache4, gõ lệnh sau để cài đặt:

# yum install ea-apache24-mod_env.x86_64

 

Rate This Article

Rate this post

Leave A Comment?